Today I got an error while installing vue-cli with yarn
yarn install v1.12.3
[1/5] Validating package.json…
[2/5] Resolving packages…
[3/5] Fetching packages…
info [email protected]: The platform “win32” is incompatible with this module.
info “[email protected]” is an optional dependency and failed compatibility check. Excluding it from installation.
error [email protected]: The engine “node” is incompatible with this module. Expected version “>=4 <=9”. Got “10.14.2”
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
After this setting, it will work.
yarn config set ignore-engines true
The reason is as follows.
My node.js installer is version 8.2, v8.9 or higher is required to support vue-cli version 3.0 or higher
- error [email protected]: The engine “node” is incompatible with this module.
- [xviz] ./scripts/run-kitti-example.sh Excute Error: gyp ERR! Node-gyp failed to build your package.
- Cannot findmodule’webpack-cli/bin/config-yargs
- Mac download wepy error reporting solution
- NPM install error: NPM err! code EINTEGRITY
- [Solved] NPM installation error: error: eacces: permission denied
- npm install: npm ERR! errno -4048, Error: EPERM: operation not permitted[How to Solve]
- [Solved] Module build failed: Error: Node Sass version 6.0.0 is incompatible with ^4.0.0.
- Project startup error: related to modules and node versions
- How to Use Yarn instead of NPM