[Solved] CentOS install docker error: package docker-ce-3:19.03.2-3.el7.x86_64 requires containerd.io >= 1.2.2-3…

Error Message:

package docker-ce-3:19.03.2-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed
– cannot install the best candidate for the job
– package containerd.io-1.2.2-3.3.el7.x86_64 is excluded
– package containerd.io-1.2.2-3.el7.x86_64 is excluded
– package containerd.io-1.2.4-3.1.el7.x86_64 is excluded
– package containerd.io-1.2.5-3.1.el7.x86_64 is excluded
– package containerd.io-1.2.6-3.3.el7.x86_64 is excluded
(try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

Check that the containerd.io package is installed, but the version is 1.2.0; so the reason for this installation failure is that the containerd.io package version is too low

Solution:

1. Check the Docker version, install the low version, and do not install the new version of Docker (I won’t bother to introduce the installation process of the low version here)

[[email protected] ~]# yum list docker-ce –showduplicates | sort -r //check the corresponding package version

 

[[email protected] ~]# yum -y install  docker-ce-18.06.0.ce-3.el7     //安装低版本的软件包

2.安装新版的containerd.io软件包

containerd.io软件包下载地址:https://download.docker.com/linux/centos/7/x86_64/edge/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm

[[email protected] ~]#wget https://download.docker.com/linux/centos/7/x86_64/edge/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm    //下载相关软件包

[[email protected] ~]# yum -y install containerd.io-1.2.6-3.3.el7.x86_64.rpm    //升级containerd.io软件包

安装完成后重新安装Docker

[[email protected] ~]# yum -y install docker-ce    //安装Docker软件包

安装完成后启动Docker

[[email protected] ~]# systemctl  start docker      //CentOS7启动方法

[[email protected] ~]#server  docker start        //CentOS6启动方法

查看状态后发现已经启动成功

Similar Posts: