CocoaPods could not find compatible versions for pod [How to Solve]

The solution is to run :
pod repo update –verbose
Then execute the command:
pod install
If there is still an error, delete the podfile.lock file
If you still get an error, delete the third-party library version and run pod install again.

// The following is the problem of the error

superlee-MacBook-Pro ios_code_new_warehouse % pod install
Analyzing dependencies
[!] The version of CocoaPods used to generate the lockfile (1.11.0) is higher than the version of the current executable (1.10.1). Incompatibility issues may arise.
[!] CocoaPods could not find compatible versions for pod "JMLink":
In snapshot (Podfile.lock):
JMLink (= 1.2.4)

In Podfile:
JMLink (= 1.2.4)

None of your spec sources contain a spec satisfying the dependencies: `JMLink (= 1.2.4), JMLink (= 1.2.4)`.

You have either:
* out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
* mistyped the name or version.
* not added the source repo that hosts the Podspec to your Podfile.
[email protected] ios_code_new_warehouse % pod install
Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod "JMLink":
In Podfile:
JMLink (= 1.2.4)

None of your spec sources contain a spec satisfying the dependency: `JMLink (= 1.2.4)`.

You have either:
* out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
* mistyped the name or version.
* not added the source repo that hosts the Podspec to your Podfile.

Similar Posts: