Python 3: How to Solve Demjson Install Error

The following error occurs when Python 3 installs demjson 2.2.4

error in demjson setup command: use_2to3 is invalid

Since demjson 2.2.4 is compatible with python2 and python3, some code needs to be converted when the installation environment is python3

Setuptools no longer supports 2to3 builds from version 58.0.0, so demjson 2.2.4 is no longer available after installation,

It can be solved by demoting the version of setuptools

pip install --upgrade setuptools==57.5.0

Similar Posts: